dotfiles/modules/common/neovim/config/toggleterm.nix
Noah Masur 97f99a149e
revert toggleterm float opts
they stuck to the height of the terminal window at initial open, which
looked bad whenever it changed, especially if it increased.
2024-06-28 20:36:08 -04:00

25 lines
518 B
Nix

{
pkgs,
dsl,
config,
...
}:
{
# Toggleterm provides a floating terminal inside the editor for quick access
plugins = [ pkgs.vimPlugins.toggleterm-nvim ];
use.toggleterm.setup = dsl.callWith {
open_mapping = dsl.rawLua "[[<c-\\>]]";
hide_numbers = true;
direction = "float";
};
lua = ''
${builtins.readFile ./toggleterm.lua}
${if config.github then (builtins.readFile ./github.lua) else ""}
${if config.kubernetes then (builtins.readFile ./kubernetes.lua) else ""}
'';
}