dotfiles/modules/nixos/hardware/default.nix
2024-04-20 09:42:06 -04:00

23 lines
390 B
Nix

{ lib, ... }:
{
imports = [
./audio.nix
./boot.nix
./disk.nix
./keyboard.nix
./monitors.nix
./mouse.nix
./networking.nix
./server.nix
./sleep.nix
./wifi.nix
./zfs.nix
];
options = {
physical = lib.mkEnableOption "Whether this machine is a physical device.";
server = lib.mkEnableOption "Whether this machine is a server.";
};
}