mirror of
https://github.com/nmasur/dotfiles
synced 2025-02-07 11:02:04 +00:00
25 lines
420 B
Nix
25 lines
420 B
Nix
{ config, lib, ... }:
|
|
|
|
let
|
|
cfg = config.nmasur.presets.programs.notmuch;
|
|
in
|
|
|
|
{
|
|
|
|
options.nmasur.presets.programs.notmuch.enable = lib.mkEnableOption "Notmuch mail indexing";
|
|
|
|
config = lib.mkIf cfg.enable {
|
|
# Better local mail search
|
|
programs.notmuch = {
|
|
enable = true;
|
|
new.ignore = [
|
|
".mbsyncstate.lock"
|
|
".mbsyncstate.journal"
|
|
".mbsyncstate.new"
|
|
];
|
|
};
|
|
|
|
};
|
|
|
|
}
|