mirror of
https://github.com/nmasur/dotfiles
synced 2025-02-07 05:12:02 +00:00
27 lines
571 B
Nix
27 lines
571 B
Nix
{ lib, ... }:
|
|
|
|
{
|
|
|
|
options.theme = {
|
|
name = lib.mkOption {
|
|
type = lib.types.nullOr lib.types.str;
|
|
description = "Color palette name (fallback when individual colors aren't specified)";
|
|
default = null;
|
|
};
|
|
colors = lib.mkOption {
|
|
type = lib.types.attrs;
|
|
description = "Base16 color scheme.";
|
|
default = (import ../colorscheme/gruvbox).dark;
|
|
};
|
|
mode = lib.mkOption {
|
|
type = lib.types.enum [
|
|
"light"
|
|
"dark"
|
|
];
|
|
description = "Light or dark mode";
|
|
default = "dark";
|
|
};
|
|
};
|
|
|
|
}
|